Intel82574 ProSet – VLAN – Windows 8.1

Okey, Just spent my weekend trying to get my VMware workstation up and running with VLANs, guess it shouldn’t be as easy as I thought.

My first major problem, what do I do?
I had never tried running VLAN / Trunk on a consumer OS, Windows Server? Linux? Sure, no problem…
But after googling, It looks pretty straight forward. As longs as your NIC support dot1q, your good to go, you only need to replace the build-in drivers from windows, with either Intel or Realtek. Mine is an Intel onboard nic, so ProSet should be my answer. But after trying every possible combination on installing Proset, Both my NICs stayed truthfully to the  Microsoft drivers…

Let’s force ’em..!
Open Device manager, and find your Network Adapter
Right click and select: Update Driver Software
And the the following steps.
-> Browse my computer for driver software
-> Let me pick from a lit of device driver on my computer
-> Have disk
C:\Users\username\Downloads\PROWinx64\PRO1000\Winx64\NDIS64
Pick Intel(R)) 82579LM Gigabit Network Connection from Network Adapter list
Finish the driver update.

This takes for granted that you have already download the intel PROSET bundle.

As you can see, I have now changed my driver for NIC2, and I’ve added a VLAN

device manager

If you look closely you should see that I’m actually running a 82579LM driver on a 82574L chipset, but hey it looks like it’s working perfectly… This is probably why the the Intel ProSET installer didn’t automagically update the drivers correctly..

Leave a Comments